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Prefață

Aplicația Ansys Electromagnetics Suite poate soluționa o gamă foarte mare de
probleme: de câmp electromagnetic la frecvențe mici și mari, de câmp termic
etc. Ea folosește metoda elementului finit pentru soluționarea numerică a pro-
blemelor de câmp.

În acest îndrumar vom descrie modul în care putem soluționa câteva pro-
bleme de câmp electromagnetic la frecvențe joase utilizând versiunea 19.2.0 a
aplicației.

Îndrumarul își propune să familiarizeze cititorul cât mai rapid cu aplicația
și opțiunile acesteia. Drept urmare, multe din caracteristicile mai avansate
ale programului nu vor fi prezentate. O bună parte din caracteristici vor fi
studiate în timpul laboratorului de Software pentru câmp electromagnetic când
vom analiza și alte tipuri de probleme.

Plec de la premiza că cititorul este familiarizat cu noțiunile de bază ale teo-
riei câmpului electromagnetic și că are cunoștințe elementare legate de metoda
elementului finit.
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1 | Elementele de bază ale
aplicației

Rulăm programul cu ajutorul pictogramei

.

1.1 Interfața grafică cu utilizatorul
Fereastra programului este împărțită în mai multe părți (fig. 1.1):

• Meniul 1 ;

• Bara de unelte 2 ;

• Project Manager (Panoul de gestiune a proiectului) 3 – conține elemen-
tele de bază ale problemei: condiții de frontieră, excitații, opțiuni analiză
etc;

• Properties (Panoul de proprietăți) 4 – permite accesarea proprietăților
elementelor selectate în spațiul de lucru 7 : dimensiuni, denumiri, culori
etc;

• Message Manager (Panoul de gestiune a mesajelor) 5 – afișează mesaje
cu privire la derularea programului (erori, avertismente etc.);

• Progress (Panoul de derulare a execuției) 6 – afișează etapa de execuție
a simulării (timpul rămas până la obținerea soluției, etc);

• Spațiul de lucru 7 – aici prelucrăm geometria, asociem materiale și
vizualizăm rezultate.
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Figura 1.1: Interfața grafică a programului Ansys Electronics Desktop.

1.2 Setarea tipului de problemă
Pentru soluționarea unei probleme de câmp electromagnetic în care neglijăm
propagarea undelor electromagnetice, folosim modulul Maxwell 3D sau Maxwell
2D. Mai întâi ne asigurăm că există un proiect în Project manager 3 . Dacă
nu există, adăugăm unul nou dând click pe New. Apoi, din Bara de unelte >
Desktop 2 , adăugăm un modul Maxwell 3D (fig. 1.2).

Figura 1.2: Adăugare modul Maxwell 3D.

Fereastra capătă aspectul din fig. 1.3.
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Figura 1.3: Fereastra programului cu modulul Maxwell 3D.

Tipul de problemă (regimul câmpului electromagnetic) se setează din Meniu
> Maxwell 3D > Solution Type. Apare fereastra din fig. 1.4 în care putem
opta pentru regimul dorit.

Figura 1.4: Stabilirea regimului câmpului electromagnetic.

1.3 Modelarea
Unitățile de măsură se pot stabili folosind Bara de unelte [Draw] > Units.
Tot aici se stabilește și materialul asociat fiecărei noi structuri pe care o desenăm.
Acestea și alte opțiuni sunt descrise în fig. 1.5.

Figura 1.5: Opțiunile de desenare.
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1.4 Un mic exemplu de desenare
Vrem să desenăm paralelipipedul din fig. 1.6 având colțul situat în punctul de
coordonate (x, y, z) = (0, 0, 0) și având dimensiunile dX×dY ×dZ = 10×100×
10mm.

Figura 1.6: Un paralelipiped situat în punctul de coordonate
(x, y, z) = (0, 0, 0) și având dimensiunile dX × dY × dZ = 10× 100× 10mm.

Îl putem construi cu mouse-ul sau manual, introducând valorile în colțul din
dreapta jos al ferestrei, sărind cu tasta Tab de la o valoare la alta (fig. 1.7).

Figura 1.7: Introducerea de la tastatură a datelor pentru paralelipiped:
(x, y, z) = (0, 0, 0), dX × dY × dZ = 10×100×10mm.

Dacă ulterior desenării constatăm că am greșit sau dorim să schimbăm di-
mensiunile obiectului, nu este nevoie să îl ștergem și să desenăm altul. În partea
stângă a spațiului de lucru 7 selectăm pictograma galbenă Create box
(fig. 1.8) dăm dublu-click sau modificăm dimensiunile din Properties 4 . Pa-
ralelipipedul are acum dX × dY × dZ = 20× 100× 10mm.
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Figura 1.8: Modificarea dimensiunilor paralelipipedului: selecția, modificarea
și aspectul ulterior.

Vrem să duplicăm acest paralelipiped de-a lungul axei Ox. Selectăm obiectul
dând click pe el, apoi în bara de unelte 2 selectăm opțiunea Duplicate
Along Line(fig. 1.9). Îl copiem de-a lungul axei cu 60mm, și creăm trei versiuni
ale acestui obiect (fiecare situate la 60mm una față de cealaltă). Folosim mouse-
ul sau introducem valorile în colțul dreapta jos. Nu uităm să setăm valoarea 3
în câmpul „Total number”. Dacă am introdus valori greșite le putem modifica
oricând, selectând pictograma galbenă DuplicateAlongLine din partea stângă
a spațiului de lucru 7 . Rezultatul arată ca în fig. 1.10.

Figura 1.9: Duplică de-a lungul unei linii.

Figura 1.10: După duplicare de-a lungul unei linii.
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Vrem să realizăm o gaură de secțiune circulară ce trece prin centrul primului
paralelipiped. Cilindrul trebuie să aibă proprietățile din fig. 1.11. Ca să îl pu-
tem vedea mai bine putem selecta primul paralelipiped și schimba transparența
acestuia din Properties 4 .

Figura 1.11: Proprietățile cilindrului.

Cilindrul ocupă o porțiune din paralelipiped. Vrem să eliminăm din para-
lelipiped acea zonă ocupată de cilindru. Selectăm ambele obiecte. Selectăm
opțiunea Subtract din bara de unelte și ne asigurăm că cele două entități
sunt plasate în ordinea corespunzătoare (fig. 1.12).

Figura 1.12: Realizarea unei găuri în paralelipiped.

Rezultă geometria din fig. 1.13.
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Figura 1.13: Geometria văzută de sus, după realizarea găurii cilindrice.

Pentru unirea mai multor obiecte într-unul singur se utilizează opțiunea
Unite din bara de unelte.

În metoda elementului finit lucrăm cu domenii mărginite. Deci trebuie să
înconjurăm domeniul de calcul cu o suprafață închisă (o frontieră). O putem
face manual sau putem folosi direct comanda rapidă Bara de unelte > Create
Region. În cazul de față am optat pentru All/Percentage Offset/50.

Figura 1.14: Opțiunea create region.

Dacă dorim să selectăm o față a unui obiect, în bara de unelte alegem Bara
de unelte > Select:Face în loc de Select:Object. O alternativă constă în
apăsarea tastei F. Dacă fața pe care vrem să o selectăm se află în spatele unei
alte fețe, selectăm fața de deasupra apoi apăsăm B (de la Back) de la tastatură
și se va selecta automat fața din spatele celei selectate inițial.
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2 | Calcul de capacități

2.1 Cerințele și datele problemei
Să se calculeze câmpul electric și capacitățile din structura reprezentată în fig.
2.1. Linia microstrip din figură este formată din doi conductori (portocaliu)
plasați pe un substrat dintr-un dielectric (mov) având permitivitatea relativă
εr = 10. Acestea sunt plasate în interiorul unei carcase conductoare (peretele
lateral). Între pereții carcasei și dielectric se află aer. Grosimea h a depunerii
de cupru este foarte mică.
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Figura 2.1: Dimensiunile liniei microstrip. În figura de jos este desenată
structura (fără carcasă) văzută de sus.
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2.2 Tipul problemei, unități
Structura dată nu este plan-paralelă sau axi-simetrică. Vom avea, deci, o pro-
blemă tridimensională. În bara de unelte adăugăm modulul: Bara de unelte
> Maxwell > Maxwell 3D.

Știm că în problemă nu apar curenți și nu există transformări de energie. Ni
se cer capacitățile, deci analizăm structura în regimul cel mai simplu ce ne per-
mite acest lucru: regimul electrostatic. În Meniu > Maxwell 3D > Solution
Type selectăm opțiunea Electrostatic. Ne asigurăm că unitatea de măsură
pentru distanță este setată în milimetri: Bara de unelte [Draw] > Units.

2.3 Geometria
Construim paralelipipedul corespunzător dielectricului având proprietățile geo-
metrice din fig. 2.2a cu comanda Bara de unelte [Draw] > Draw box ( ).
Ca să afișăm întreaga imagine pe ecran apăsăm Ctr+D la tastatură. Carcasa o
construim în mod similar, folosind opțiunile din fig. 2.2b.

(a) Dielectricul. (b) Carcasa.

Figura 2.2: Proprietățile geometrice ale dielectricului și carcasei.

Obținem desenul din fig. 2.4a unde am fixat transparența carcasei (obiectul
Box2 din stânga spațiului de lucru) la valoarea de 0, 8 în panoul Properties.

Urmează desenarea conductorilor depuși pe dielectric. Pentru a ne ușura
desenul vom ascunde carcasa dând click pe pictograma din Bara de unelte
[Draw]. Carcasa nu e ștearsă ci doar ascunsă. Dacă vrem să controlăm vizibi-
litatea obiectelor le putem lista dând click pe pictograma .

Deoarece înălțimea h a conductorilor din fig. 2.1 este foarte mică, atunci
când îi desenăm o putem neglija. Cei doi conductori vor avea, deci, forma unor
suprafețe plane dreptunghiulare. Prima suprafață dreptunghiulară are propri-
etățile geometrice din fig. 2.3a. A doua suprafață se obține prin cu operația
Duplicate along line ( ) din Bara de unelte [Draw] (2.3b).
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(a) Prima suprafață dreptunghiulară. (b) A doua suprafață dreptunghiulară.

Figura 2.3: Proprietățile geometrice ale suprafețelor conductoare.

Rezultă geometria din fig. 2.4b.

(a) Carcasa și dielectricul. (b) Carcasa, dielectricul și conductoarele.

Figura 2.4: Structura desenată

Ca să putem identifica cu ușurință varietățile geometrice ce apar în structura
analizată este recomandat să le redenumim. Face acest lucru selectându-le în
panoul din stânga spațiului de lucru și modificându-le denumirile în panoul
Properties (fig. 2.5).
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(a) Înainte. (b) După.

Figura 2.5: Redenumirea obiectelor geometrice din model.

2.4 Materialele
În bara de unelte, partea dreaptă, găsim meniul cu materiale. Selectăm die-
lectricul. Apoi dăm click pe Bara de unelte[Draw] > Material și în fereastra
nou apărută alegem Add Material.... În noua fereastră (fig. 2.6) creăm un
nou material cu denumirea Diel și permitivitatea electrică relativă εr = 10.
Selectăm carcasa și îi asociem materialul air ce este deja predefinit în librăria
de materiale a programului.

Figura 2.6: Crearea unui nou material având proprietățile date în cerințele
problemei.
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2.5 Excitațiile
Pentru a putea calcula în mod corespunzător capacitățile trebuie să impunem
potențiale pe conductoarele din problemă.

Avem trei conductoare în total: cele două trasee de cupru depuse pe dielectric
și carcasa (pereții laterali) ce mărginește structura. Deci, vom defini trei condiții
de frontieră.

Ne asigurăm că e ales modul de selecție al fețelor (apăsăm F de la tastatură).
Dăm click pe fața pe care vrem să o selectăm (apăsăm B de la tastatură dacă
vrem să selectăm fața din spatele celei selectate).

Selectăm primul conductor. Click dreapta, apoi Assign Excitation > Voltage.
Îi dăm denumirea V1 și impunem valoarea potențialului scalar de 1V. Îm mod
similar procedăm cu cel de-al doilea conductor: dăm denumirea V2 excitației
și punem valoarea −1V. Selectăm pereții laterali ai frontierei domeniului, pu-
nem excitația cu denumirea V0 și îi dăm valoarea 0V. Cele trei excitații sunt
prezentate în fig. 2.7.

(a) (b) (c)

Figura 2.7: Impunerea potențialelor pe conductori.

2.6 Condițiile de frontieră
Cele trei excitații anterioare reprezintă condiții de frontieră de tip Dirichlet
pentru structura analizată de noi. Pe ceilalți doi pereți din cei 6 ai paralelipipe-
dului ce mărginește domeniul de calcul vrem să impunem condiția de frontieră
Neumann ∂V

∂n = 0. Aceasta este pusă în mod automat de program.

2.7 Rețeaua de discretizare
La această problemă nu modificăm, deocamdată, setările legate de rețeaua de
discretizare.

2.8 Analiza problemei
Înainte să analizăm problema, trebuie să dăm comanda pentru calculul capacită-
ților în etapa de postprocesare. În panoul Project manager dăm click dreapta
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pe Parameters > Assign > Matrix și selectăm cele trei excitații în fereastra
nou apărută. Programul ne va calcula capacitățile ce apar între conductoare.

Realizăm o comandă de analiză. În Project manager dăm click dreapta pe
Analysis > Add Solution Setup. Lăsăm opțiunile implicite ale programului.

Înainte să efectuăm analiza, realizăm validarea modelului nostru. În bara de
unelte dăm click pe Bara de unelte [Simulation] > Validate. Dacă totul
este în regulă ar trebui să obținem fereastra din fig. 2.8.

Figura 2.8: Validarea modelului.

În panoul Project Manager dăm click dreapta pe Analysis > Analyze
All. În panoul Progress putem urmări evoluția execuției programului.

2.9 Postprocesarea
Valoarea capacităților calculate se afișează astfel: în panoul Project Manager
dăm click dreapta pe Results apoi selectăm Solution data. Obținem capaci-
tățile din fig. 2.9 considerate în pF.

Figura 2.9: Capacitățile calculate de program.

Exercițiul 2.1 Care este interpretarea capacităților din tabelul din fig. 2.9?

Vrem să reprezentăm potențialul electric scalar în spațiu. Selectăm obiec-
tele Domeniu și Substrat, click dreapta, Fields > Voltage, All Objects,
Done. Obținem suprafețele echipotențiale din fig. 2.10a. Dacă dorim un alt tip
de reprezentare dăm click dreapta pe Project Manager > Fields Overlay >
Voltage; selectăm tab-ul Plots în noua fereastră apărută și alegem opțiunea
Cloud. Obținem graficul din fig. 2.10b.
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(a) Suprafețele echipotențiale ale lui V . (b) Potențialul V reprezentat cu opțiunea
cloud.

Figura 2.10: Potențialul electric scalar V . Două reprezentări.

Deși uneori este utilă, reprezentarea tridimensională a unei mărimi poate fi
greu de urmărit. În anumite situații e mai util să vedem cum variază mărimea
pe o anumită suprafață. Pentru a putea vizualiza această variație, putem să
desenăm suprafața respectivă în preprocesare.

De exemplu, vrem să reprezentăm potențialul electric scalar V pe două su-
prafețe perpendiculare între ele ce se intersectează în centru. O modalitate
simplă de a le desena este următoarea. Selectăm Bara de unelte [Draw] >
Relative CS: Offset și desenăm cu mouse-ul în centrul structurii un nou sis-
tem de coordonate. Apoi selectăm obiectul Domeniu și dăm click pe Bara de
unelte [Draw] > Surface > Section.... În fereastra nou apărută alegem
planul Y Z. Reluăm procedeul și alegem planul XZ. Obținem desenul din fig.
2.11a. Soluționăm problema din nou și obținem graficele din fig. 2.11b.

(a) Secțiunile structurii. (b) Potențialul V reprezentat pe secțiuni.

Figura 2.11: Reprezentarea potențialului pe mai multe secțiuni.
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Exercițiul 2.2 Explicați de ce potențialul de pe secțiunea mai mică este nul în
fiecare punct.

Potențialul electric scalar V de-a lungul secțiunii mai mari arată ca în fig.
2.12a. Rețeaua de discretizare pe această secțiune se afișează selectând-o apoi
dând click dreapta: Plot mesh....

(a) Potențialul V pe secțiunea mare. (b) Rețeaua de discretizare pe secțiunea
mare.

Figura 2.12: Reprezentarea potențialului și a rețelei pe secțiune.

Exercițiul 2.3 Analizând rezultatul din fig. 2.12a estimați acuratețea soluției.
Care este concluzia și ce ne spune aceasta despre rezultatul afișat în fig. 2.9?
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3 | Analiza unui electromag-
net de curent continuu

3.1 Cerințele și datele problemei
Să se calculeze câmpul magnetic și forța ce acționează asupra armăturii mobile
a electromagnetului de curent continuu de tip E-I din fig. 3.1. Acesta are
grosimea g=40mm. Bobina are forma din fig. 3.1.

120

40 60

40

20 20

20

20
d=2

20

20

Figura 3.1: Dimensiunile electromagnetului de tip E-I. În figura de jos este
desenată armătura mobilă și bobina văzute de jos.

Miezul este realizat dintr-un material magnetic liniar având permeabilitatea
magnetică relativă µr = 4000. Bobina este realizată din cupru. Electromagnetul
este plasat în aer. Bobina are 3200 de spire și este parcursă de curentul continuu
de intensitate I = 1A.

Să se înlocuiască materialul liniar din care este realizat miezul cu unul neli-
niar și să se reprezinte grafic variația forței cu curentul.
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3.2 Tipul problemei, unități
Deoarece curentul prin bobină este constant în timp, avem un regim mag-
netic staționar. Setăm opțiunea Magnetostatic în Meniu > Maxwell 3D >
Solution Type. Ne asigurăm că unitatea de măsură pentru distanță este setată
în milimetri.

3.3 Geometria
Construim mai întâi armătura mobilă având proprietățile geometrice din fig.
3.2a cu comanda Bara de unelte > Draw > Draw box ( ).

(a) Armătura mobilă. (b) Duplicarea armăturii mobile.

Figura 3.2: Proprietățile geometrice ale armăturii mobile și duplicării

Duplicăm armătura mobilă Bara de unelte > Draw > Duplicate Along
Line ( ), copiind-o cu 62mm în sus, de-a lungul axei Oz (fig. 3.2b).

Construim coloana din stânga având proprietățile din fig. 3.3a, iar apoi o
duplicăm de-a lungul axei Oy cu opțiunile din fig 3.3b. Duplicarea ne creează
coloana din dreapta.

(a) Coloana stângă. (b) Duplicarea coloanei stângi.

Figura 3.3: Proprietățile geometrice pentru coloana stângă și duplicarea ei.

Construim coloana centrală cu opțiunile din fig. 3.4a. Geometria arată ca
în fig. 3.5a. Observăm cum cele patru coloane ale armăturii superioare se su-
prapun. Ca să rectificăm acest lucru (din punct de vedere fizic două corpuri nu
pot ocupa aceeași poziție simultan) și ca să obținem un singur corp, utilizăm co-
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manda Bara de unelte > Unite( ) după ce le selectăm (cu Ctrl+click).
Rezultă geometria din fig. 3.5b.

(a) Coloana centrală. (b) Bobina.

Figura 3.4: Proprietățile geometrice ale coloanei centrale și ale bobinei.

(a) (b)

Figura 3.5: Armăturile mobile înainte și după reuniunea coloanelor armăturii
superioare.

Bobina este situată în jurul coloanei centrale. Din fig. 3.1 rezultă că trebuie
să desenăm un paralelipiped de înălțime 40mm ce este centrat pe armătura
centrală și are baza un pătrat de latură 80mm. Selectăm Bara de unelte >
Create box cu opțiunile din fig. 3.4b și obținem geometria din fig. 3.7a.

În fig. 3.7a am schimbat culorile fiecărui obiect (din panoul Properties)
pentru a putea fi identificat mai ușor. Ca să putem identifica și mai repede
obiectele este recomandat să le redenumim, utilizând panoul din stânga spațiului
de lucru (fig. 3.6).

20



George Marian Vasilescu

(a) Înainte. (b) După.

Figura 3.6: Redenumirea obiectelor geometrice din model.

Bobina încă nu este desenată. În clipa de față este doar un paralelipiped ce
ocupă aceeași poziție în spațiu cu coloana centrală. Vrem să eliminăm partea
din bobină prin care trece coloana centrală. Selectăm bobina, apoi coloana
centrală, apoi dăm click pe Bara de unelte > Subtract. Apare fereastra din
fig. 3.8. Ne asigurăm că avem opțiunile setate ca în fig. 3.8. Obținem geometria
din fig. 3.7b unde pentru armătura fixă am setat o transparență de 0, 52.

(a) (b)

Figura 3.7: Geometria finală: armăturile și bobina.
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Figura 3.8: Opțiunile pentru găurirea bobinei

Frontiera domeniului de calcul se construiește cel mai simplu cu coman-
da Bara de unelte > Create Region din bara de unelte. Utilizăm opțiunile:
All/Percentage Offset/50.

3.4 Materialele
În bara de unelte, partea dreaptă, găsim meniul cu materiale. Mediul implicit
ce a fost asociat tuturor corpurilor din model este vidul („vacuum”). Selectăm
bobina și din meniul cu materiale alegem Select… și căutăm cuprul din librăria
de materiale. Selectăm armăturile, dăm click pe Material și în fereastra nou
apărută alegem Add Material…. În noua fereastră (fig. 3.9a) creăm un nou
material cu denumirea „Fe” și permeabilitatea magnetică relativă 4000. Panoul
din stânga spațiului de lucru ar trebui să arate ca în fig. 3.9b. În loc de vacuum
putem pune aer, însă rezultatul va fi același deoarece ambele medii au aceeași
permeabilitate magnetică.
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(a) Realizarea unui nou material (b) Organizarea obiectelor în funcție de
materiale

Figura 3.9: Operații cu materiale.

3.5 Excitațiile
Bobina este parcursă de un curent I = 1A și are 3200 de spire. Trebuie să fixăm
bornele bobinei. Facem acest lucru în felul următor.

Selectăm cele două armături și domeniul de aer și dăm click pe pictograma
. În felul acesta le ascundem. Nu pierdem din vedere că acestea nu sunt șterse

ci doar ascunse! Folosim această opțiune când vrem să vedem mai bine anumite
zone mai greu accesibile din modelul nostru. Dacă vrem să vedem o listă cu
toate obiectele ascunse sau vizibile dăm click pe pictograma .

Creăm un nou sistem de coordonate atașat bobinei. Selectăm bobina și în
bara de unelte alegem Object CS > Offset. Ne asigurăm că noul sistem de co-
ordonate are proprietățile din fig. 3.10a. Ne asigurăm că lucrăm în acest sistem
de coordonate selectându-l în panoul stâng: Coordinate systems. Selectăm
bobina și dăm click în bara de unelte pe Surface > Section apoi alegem
secțiunea în planul Y Z. Rezultatul este afișat în fig. 3.10b.

Din cele două secțiuni ne trebuie doar una. Selectăm, în meniu, coman-
da: Meniu > Modeler > Boolean > Separate Bodies. După ce separăm cele
două secțiuni, selectăm una și o ștergem.

Selectăm cealaltă secțiune, click dreapta, Assign excitation > Current.
Punem valorile din fig. 3.11a.
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(a) Sistemul de coordonate atașat bobinei. (b) Bobina secționată.

Figura 3.10: Secționarea bobinei

(a) Impunerea solenației bobinei (b) Stabilirea rețelei de discretizare

Figura 3.11: Impunerea solenației bobinei. Stabilirea rețelei de discretizare.

3.6 Condițiile de frontieră
Selectăm obiectul bobină, click dreapta, Assign boundary>Insulating.... Aceas-
tă condiție îi spune programului că densitatea de curent nu „iese” în afara bo-
binei.

Programul pune automat restul condițiilor de frontieră corespunzătoare.

3.7 Rețeaua de discretizare
La această problemă nu modificăm, deocamdată, setările legate de rețeaua de
discretizare.

De cele mai multe ori, programul stabilește în mod corespunzător parametrii
rețelei de discretizare. Dacă vrem un control mai bun asupra rețelei, avem mai
multe opțiuni disponibile. Cea mai la îndemână este descrisă în continuare.

Mai întâi am selecta obiectele ale căror rețea vrem să o impunem. În cazul de
față: armăturile (în interiorul acestora câmpul variază în spațiu cel mai intens).
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În panoul Project manager dăm click dreapta pe Mesh Operations > Assign
> Inside Selection > Lengh Based și putem pune opțiunile din fig. 3.11b.

3.8 Analiza problemei
Înainte să analizăm problema, trebuie să îi spunem programului că vrem să ne
calculeze forța în etapa de postprocesare. Selectăm armătura mobilă. În panoul
Project manager dăm click dreapta pe Parameters > Assign > Force.

Realizăm o comandă de analiză. În Project manager dăm click dreapta pe
Analysis > Add Solution Setup. Lăsăm opțiunile implicite ale programului.

Înainte să efectuăm analiza, realizăm validarea modelului nostru. În bara de
unelte dăm click pe Bara de unelte [Simulation] > Validate. Dacă totul
este în regulă ar trebui să obținem fereastra din fig. 3.12.

Figura 3.12: Validarea modelului.

3.9 Postprocesarea
Valoarea forței calculate se afișează astfel: în panoul Project Manager dăm
click dreapta pe Results apoi selectăm Solution data. Obținem o forță de
1628, 5N pe direcția Oz. Pe celelalte direcții forța ar trebui să fie nulă.
Exercițiul 3.1 Explicați de ce forța pe direcțiile Ox, Oy ar trebui să fie nulă.
Explicați de ce nu este nulă.

Dacă dorim să vizualizăm rețeaua de discretizare, selectăm domeniile pentru
care vrem să vizualizăm, apoi în panoul Project Manager dăm click dreapta
pe Field Overlays și alegem Plot Mesh.... Rețeaua de discretizare pentru
bobină și miez (nu și aer) arată ca în fig. 3.13a.
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(a) Rețeaua de discretizare
pentru cele două armături și

bobină.

(b) Vectorul inducție magnetică în armături

Figura 3.13: Afișări în postprocesare.

Dacă dorim să vizualizăm vectorul inducție magnetică în armături, mai în-
tâi le selectăm, apoi în panoul Project Manager dăm click dreapta pe Field
Overlays și alegem Filelds > B > B_vector. Obținem graficul din fig. 3.13b.
Exercițiul 3.2 Cum estimați acuratețea soluției?

Exercițiul 3.3 Ce ați putea face pentru a verifica dacă soluția numerică este
exactă?

3.10 Parametrizarea problemei
Ultima cerință a problemei ne cere înlocuirea materialului armăturilor cu unul
neliniar și realizarea graficului forței magnetice în funcție de curent.

Materialul se înlocuiește selectând cele două armături și dând click pe Bara
de unelte > Material. În listă căutăm steel_1008 și apăsăm OK.
Exercițiul 3.4 Afișați caracteristica B-H a acestui material.

A doua parte a cerinței implică soluționarea unei succesiuni de probleme
(pentru diverși curenți). Ansys ne permite să automatizăm acest proces.

În panoul Project Manager dăm dublu-click pe Excitations > Current1.
În fereastra nou apărută scriem I_bob*3200 în loc de 1*3200 (fig. 3.14a). Ansys
definește automat variabila I_bob și ne afișează o fereastră nouă (fig. 3.14b) în
care ne cere tipul, unitatea și valoarea acesteia. Punem valorile din figură.
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(a) Folosirea variabilei I_bob. (b) Definirea variabilei I_bob.

Figura 3.14: Definirea curentului ca o variabilă.

În panoul Project Manager dăm click dreapta pe Optimetrics. Apoi Add
> Parametric. În fereastra nou apărută dăm click pe Add, punem valorile din
fig. 3.15 și dăm click pe butonul Add >> din centrul ferestrei.

Figura 3.15: Setarea valorilor variabilei I_bob.

În panoul Project Manager dăm click dreapta pe Optimetrics. Apoi Analyze
> All. În panoul Progress putem urmări evoluția execuției programului.

După terminarea execuției în panoul Project Manager dăm click dreapta
pe Results. Apoi Create Magnetostatic Report > Rectangular plot. Fo-
losim valorile din fig. 3.16 și dăm click pe New Report.

27



George Marian Vasilescu

Figura 3.16: Obținerea graficului forței în funcție de curentul bobinei.

Obținem graficul din fig. 3.17.

Figura 3.17: Variația forței cu curentul.

Exercițiul 3.5 De ce graficul forței se „aplatizează”?

Exercițiul 3.6 Verificați valorile inducției magnetice. Determinați zona de
funcționare de pe caracteristica B − H pentru valoarea de 5A a curentului.
Estimați care este acuratețea soluției.
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4 | Soluții și indicii la pro-
bleme

Soluția 2.3 Indiciu: „forma” câmpului este dată de rețeaua de discretizare din
fig. 2.12b.

Soluția 3.1 Ar trebui să fie nulă datorită simetriei problemei. De ce?

Soluția 3.2 Indiciu: acuratețea soluției are legătură cu rețeaua de discretizare.
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